I’ve installed the product on Lubuntu 16.04.3 and made it work, the installation process involved:

  • ps-pulse-linux-5.3r4.2-b639-ubuntu-debian-64-bit-installer.deb
  • libproxy1-plugin-gsettings_0.4.11-5ubuntu1_amd64
  • libproxy1-plugin-webkit_0.4.11-5ubuntu1_amd64
  • libwebkitgtk-1.0-0_2.4.11-0ubuntu0.1_amd64
  • libjavascriptcoregtk-1.0-0_2.4.11-0ubuntu0.1_amd64

After installing those dependencies you may face an error if trying to launch the GUI from the console:

To solve that:

and then launched normally the GUI.